SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-02-16 23:08:53

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Wireless issue on t520

I recently set up my thinkpad to dual boot windows 8 and crunchbang and it runs pretty well. The problem is, it can't connect to my wireless. It detects it no problem, and prompts me for the password, but then it just continually "connects" and then prompts me for the password again, and again. I've been browsing through the forums and haven't found anything that helps. Here's what prints when running lspci (which seems to be what most people needed to help out on other similar topics):

00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
	Subsystem: Lenovo Device [17aa:21ce]
	Kernel driver in use: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 04)
--
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
	Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
	Kernel driver in use: iwlwifi
0d:00.0 System peripheral [0880]: Ricoh Co Ltd PCIe SDXC/MMC Host Controller [1180:e823] (rev 08)

If any other info is needed let me know and thanks in advance.

UPDATE:

IamFuzzles wrote:

It's definitely supported. Turns out I can connect to my universitys wifi (no password required) but not to my own. I'm using a linksys e3000 running ddwrt. The thing is, I've connected to mine on a previous install of crunchbang with no problem. So it's not impossible..

Last edited by IamFuzzles (2013-02-27 03:32:04)

Offline

Be excellent to each other!

#2 2013-02-24 19:05:49

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

Bump.

Any ideas?

Offline

#3 2013-02-24 19:50:18

fatmac
#! Die Hard
Registered: 2012-11-14
Posts: 1,948

Re: Wireless issue on t520

As nobody has chipped in, it is possible that your wifi is not supported by the present driver.
All I can suggest is that you look on the Intel site for a driver (& firmware) for your particular wifi card.


Linux since 1999
Currently:  AntiX, & Crunchbang.
A good general beginners book for Linux :- http://rute.2038bug.com/index.html.gz
A good Debian read :- http://debian-handbook.info/get/now/

Offline

#4 2013-02-27 03:30:59

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

It's definitely supported. Turns out I can connect to my universities wifi (no password required) but not to my own. I'm using a linksys e3000 running ddwrt. The thing is, I've connected to mine on a previous install of crunchbang with no problem. So it's not impossible..

Offline

#5 2013-02-27 12:01:41

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

Try upgrading your kernel to the latest version in backports.

Are you using network-manager or something else?
Show us your wifi config.

Offline

#6 2013-02-27 14:35:50

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

I think I've already upgraded. At least, there are 4 entries in Grub, two ending in -rt. I'll try again when I get home.

What will I need to post for the wifi config? And yes, I'm using network-manager

Thanks for the help

Offline

#7 2013-02-27 15:28:14

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

-rt is a realtime kernel...
Post your /boot/grub/grub.cfg to see which kernels you have installed.

For the network: post a screenshot of the different config screens you get when clicking the wireless icon.

Offline

#8 2013-02-28 02:16:40

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

Sorry, new to a lot of this still. What's a realtime kernel? Should I still upgrade to the backport kernel?

Here's grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos3)'
search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos3)'
  search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
  set locale_dir=($root)/boot/grub/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod part_msdos
insmod ext2
set root='(hd0,msdos3)'
search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
insmod png
if background_image /usr/share/images/desktop-base/grub-splash-crunchbang.png; then
  set color_normal=light-gray/black
  set color_highlight=white/black
else
  set menu_color_normal=cyan/blue
  set menu_color_highlight=white/blue
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'CrunchBang GNU/Linux, with Linux 3.2.0-4-rt-amd64' --class crunchbang --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos3)'
	search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
	echo	'Loading Linux 3.2.0-4-rt-amd64 ...'
	linux	/boot/vmlinuz-3.2.0-4-rt-amd64 root=UUID=2b5ce3db-b165-4f9d-ade2-3624877cddfb ro  quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-3.2.0-4-rt-amd64
}
menuentry 'CrunchBang GNU/Linux, with Linux 3.2.0-4-rt-amd64 (recovery mode)' --class crunchbang --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos3)'
	search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
	echo	'Loading Linux 3.2.0-4-rt-amd64 ...'
	linux	/boot/vmlinuz-3.2.0-4-rt-amd64 root=UUID=2b5ce3db-b165-4f9d-ade2-3624877cddfb ro single 
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-3.2.0-4-rt-amd64
}
menuentry 'CrunchBang GNU/Linux, with Linux 3.2.0-4-amd64' --class crunchbang --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos3)'
	search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
	echo	'Loading Linux 3.2.0-4-amd64 ...'
	linux	/boot/vmlinuz-3.2.0-4-amd64 root=UUID=2b5ce3db-b165-4f9d-ade2-3624877cddfb ro  quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-3.2.0-4-amd64
}
menuentry 'CrunchBang GNU/Linux, with Linux 3.2.0-4-amd64 (recovery mode)' --class crunchbang --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos3)'
	search --no-floppy --fs-uuid --set=root 2b5ce3db-b165-4f9d-ade2-3624877cddfb
	echo	'Loading Linux 3.2.0-4-amd64 ...'
	linux	/boot/vmlinuz-3.2.0-4-amd64 root=UUID=2b5ce3db-b165-4f9d-ade2-3624877cddfb ro single 
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initrd.img-3.2.0-4-amd64
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 8 (loader) (on /dev/sda1)" --class windows --class os {
	insmod part_msdos
	insmod ntfs
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root 9E9492F29492CBE1
	drivemap -s (hd0) ${root}
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

As for the screenshot thing, I'm not sure what you're looking for exactly, here's what I get when I try to edit the connection through network manager

Screentshot

Sorry if that's not what you're looking for.

Offline

#9 2013-02-28 11:10:10

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

Hi,
I suspect you are on Waldorf, not on stable, seeing that it is not a backported kernel.
Or did you enable the 'testing' repo perhaps?
Post output of

sudo cat /etc/apt/sources.list

My understanding is that an rt-kernel is for recording media - music for example.
Anyhow I am waiting for your response to above question to decide what to do whith the kernel.

For the network I wanted to see the screens you get when you click the 'IPv4 settings', 'IPv6 settings' if you are using IPv6 and 'Wireless Security' tab on the screen that you posted.

Remove any sensitive information from the screens - like your password. Also remove the 'Device MACaddress from the pic you posted.

Cheers

Offline

#10 2013-02-28 19:08:39

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

here's sources.list

## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
#deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://http.debian.net/debian wheezy main contrib non-free
#deb-src http://http.debian.net/debian wheezy main contrib non-free

## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main
#deb-src http://security.debian.org/ wheezy/updates main

And here are the other screenshots. Thanks again for all the help

Screenshot

Screenshot

Screenshot

Screenshot

Offline

#11 2013-03-01 11:55:13

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

Hi,
You are on Waldorf, definitely. See the sources.list output.
I don't think it is the rt kernel that is causing problems.

You said you ran #! before.
Did you perform a fresh install when you installed Waldorf, or did you install over the existing one?

There should be a config file in directory /etc/NetworkManager/system-connections/
Post the content of that file please, but overtype all sensitive information with X's.

Normally, the first time you use your wireless, it will ask for your encryption key, which it then stores in a config file under mentioned dir.
Next time it won't ask for the password again and should connect you automatically.

Make sure that the SSID in the first config screen is the one configured in the router.
Make sure that the encryption key is the one configured in the router.
SSID and 'encryption key' are two distinct tokens.

Last edited by xaos52 (2013-03-01 14:32:57)

Offline

#12 2013-03-01 15:16:05

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

It was a fresh install just like this one is, which is why I'm not sure why it's not working.

The SSID and encryption key are both correct, I'm sure of it, my windows side connects to it no problem.

As for the connection, if I let it try to connect automatically it usually won't ask for the password at first, it'll just try to connect. But then it pops up asking for it, as if it's the wrong password, and I've checked and double checked, it's correct.

Here's the config file for the connection:

[connection]
id=Jesus WRT 5GHz
uuid=XXXXXXXXXXX
type=802-11-wireless

[802-11-wireless]
ssid=Jesus WRT 5GHz
mode=infrastructure
mac-address=XXXXXXXXX
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-psk
psk=XXXXXXX

[ipv4]
method=auto
may-fail=false

[ipv6]
method=auto
ip6-privacy=2

Offline

#13 2013-03-01 16:28:22

sevensage
#! CrunchBanger
Registered: 2012-11-10
Posts: 134

Re: Wireless issue on t520

can we see

dmesg | grep iwl

and

ls /lib/firmware/ | grep iwl*

dig +short txt crunchbang.wp.dg.cx

Offline

#14 2013-03-01 16:37:20

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

dmesg | grep iwl
[    3.883719] iwlwifi 0000:03:00.0: setting latency timer to 64
[    3.883769] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[    3.883771] iwlwifi 0000:03:00.0: pci_resource_base = ffffc90000c7c000
[    3.883773] iwlwifi 0000:03:00.0: HW Revision ID = 0x34
[    3.884086] iwlwifi 0000:03:00.0: irq 42 for MSI/MSI-X
[    3.884219] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[    3.884493] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[    3.896472] iwlwifi 0000:03:00.0: device EEPROM VER=0x715, CALIB=0x6
[    3.896476] iwlwifi 0000:03:00.0: Device SKU: 0X1f0
[    3.896479] iwlwifi 0000:03:00.0: Valid Tx ant: 0X3, Valid Rx ant: 0X3
[    3.896503] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[    3.897559] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[    4.167882] iwlwifi 0000:03:00.0: firmware: agent loaded iwlwifi-6000g2a-6.ucode into memory
[    4.167889] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1
[    4.180602] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
ls /lib/firmware/ | grep iwl*
iwlwifi-1000-5.ucode
iwlwifi-100-5.ucode
iwlwifi-105-6.ucode
iwlwifi-135-6.ucode
iwlwifi-2000-6.ucode
iwlwifi-2030-6.ucode
iwlwifi-3945-2.ucode
iwlwifi-4965-2.ucode
iwlwifi-5000-2.ucode
iwlwifi-5000-5.ucode
iwlwifi-5150-2.ucode
iwlwifi-6000-4.ucode
iwlwifi-6000g2a-5.ucode
iwlwifi-6000g2a-6.ucode
iwlwifi-6000g2b-6.ucode
iwlwifi-6050-4.ucode
iwlwifi-6050-5.ucode

Now I did notice in the dmesg output it says tunable channels are bg and a. my original connection (Jesus WRT 5GHz) is set to N, however, it's a dualband router, and my other one (Jesus WRT 2.4GHz) is set to BGmix and it has the same problem as Jesus WRT 5GHz.

Offline

#15 2013-03-01 16:48:28

sevensage
#! CrunchBanger
Registered: 2012-11-10
Posts: 134

Re: Wireless issue on t520

Had a very similar issue on my mates w520 with the same Intel wireless, it was suggested then that we try the Compat-wireless drivers, your going to have to build and install them, you will find the instructions here.

It fixed his issues, unfortunately I can't seem to find his thread in the forum but your specs are identical.

Keep this on the back burner until The Doc (xaos52) returns.


dig +short txt crunchbang.wp.dg.cx

Offline

#16 2013-03-01 17:16:49

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

id=Jesus WRT 5GHz

I am wondering if this needs quotes because of  the spaces in the name?
Try

id="Jesus WRT 5GHZ"

or

id=Jesus\ WRT\ 5GHZ

or
Change the name and replace the spaces by underscores or dashes. That is if you have access to the router config.

----- TRY THIS FIRST -----

[    3.897559] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
From your dmesg indicates radio disabled.

Install package 'rfkill' and run

sudo rfkill list

to see blocks.

Last edited by xaos52 (2013-03-01 17:39:03)

Offline

#17 2013-03-01 23:19:07

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

rfkill shows no blocks. It's possible I had my wireless card switched off at that time. Changing the SSID name didn't fix the problem either. I never tried your initial suggestion to update to a backport kernel, should I give that a shot? Would I just uncomment the three links that are commented out in my sources.list?

Just wanted to say thanks again for all the help so far, really appreciate the patience.

NOTE: I have not tried sevensage's idea yet.

Offline

#18 2013-03-02 09:53:46

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless issue on t520

I suggested backports because I thought you were on Statler(stable).
There are no backports for testing and Waldorf is based on testing.

You could try installing a more recent kernel ( and network drivers ) using smxi.
Vastone has a nice tutorial on smxi.
It will allow you to install the towo-kernel ( I am using that one myself ) or the liquorix kernel.

cheers

Offline

#19 2013-03-12 00:17:11

IamFuzzles
Member
Registered: 2013-02-16
Posts: 32

Re: Wireless issue on t520

Sorry it's taken me so long to get back, been out of town.

I was an idiot, somehow, the password on my router got changed, and was one letter off from what I thought it was.

Thanks again for all the help though, I learned a lot about all this, and really appreciate. I just felt I should wrap up this thread and post the "solution"

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo