SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-12-04 22:35:42

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Intel laptop too hot solution

Possibru outdated and even harmful advice. I have no way to test this further, so modes should unsticky it.

What's wrong?

So, you bought an Intel laptop with integrated graphics, and it's running much hotter than it needs to be, Battery life also sucks. You don't know what to do. The problem in a nutshell is this. There is a feature of modern computers called Active State Power Management. Some rudimentary info: http://en.wikipedia.org/wiki/Active_Sta … Management There was a regression in kernels 2.34 to 3.4, in which the system couldn't activate ASPM properly, so heat and increased battery consumption were common. AMD chipsets mostly haven't been touched by this. There is another feature of the Intel integrated graphics controllers called RC6. It's an ACPI state that allows the card to go into serious power saving, so it consumes less power and generates less heat. There was a major bug with that one too.

Why don't I have this problem on other distros?

Well, both of these issues have been fixed upstream, starting with kernel 3.4. Sane distros that ship older kernels have backported fixes for this, but Debian in its infinite wisdom decided not to. I have no idea why, there is no sane explanation for this. The ancient 2.6.32 kernel is affected not only by this trouble, but by a lot of different stuff. 

What should I do?

You should use Waldorf, first and foremost. The Statler + BPO edition also has kernel 3.2, but there are other additions to waldorf which will help you. If you're really dead set on Statler, use the BPO edition, but you're on your own there, I'm not gonna help you. Once you've installed Waldorf, edit the relevant file. I think nano and geany are the default editors, so:

sudo nano /etc/default/grub or gksudo geany /etc/default/grub

There is a line that says:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

Change it to this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.i915_enable_rc6=1 pcie_aspm=force"

run

sudo update-grub

and reboot.

You may also find that your backlight keys aren't working and when you install xbacklight it says something like "no adapters have backlight properties". In that case you would change the line to

GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.i915_enable_rc6=1 pcie_aspm=force acpi_osi=linux acpi_backlight=vendor"

Do not follow misguided advice that tells you to put acpi=off or nolapic in the Grub line. Also, try this without the pcie_aspm=force line, because it might be that your system isn't necessarily affected by the ASPM, merely by the RC6 regression.

Last edited by el_koraco (2013-03-26 22:53:58)

Offline

Be excellent to each other!

#2 2012-12-04 23:13:48

dura
Bloated Gimp
From: interzone
Registered: 2012-09-15
Posts: 2,108

Re: Intel laptop too hot solution

At last.

Offline

#3 2012-12-05 00:56:58

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,195

Re: Intel laptop too hot solution

Just want to state that, according to what I read some time ago, "i915.i915_enable_rc6=1" seems to be for the Core i series of Intel CPUs and GPUs. Some clarification on the actual chipsets these rules apply to would be good.

"pcie_aspm=force" seems to work on all systems, though.


From Phoronix (Aug 2011):

i915.i915_enable_rc6=1 - RC6 was enabled by default for a while, but then it ended up being too buggy for some hardware configuration so it had to be disabled. For affected systems on the current code-base, enabling RC6 can cause GPU hangs. The Intel RC6 feature allows the GPU to enter a lower power state when the GPU is idling.

i915.i915_enable_fbc=1 - This kernel option enables FBC (frame-buffer compression) for the Intel graphics driver. Frame-buffer compression is not enabled by default since for some systems when frame-buffer compression is active there is a bug where the screen is not being properly repainted when using a compositing window manager. As implied by the name, frame-buffer compression will compress the buffer of what's to be drawn to the screen so that less memory bandwidth is used on screen refreshes, and as a result, less memory being confused.

i915.lvds_downclock=1 - This kernel option will down-clock the LVDS refresh rate, which can increase power savings as a result. However, for systems that do not properly support LVDS down-clocking, the screen can begin to flicker during use.

Last edited by gutterslob (2012-12-05 00:59:53)


Point & Squirt

Offline

#4 2012-12-05 01:06:56

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Intel laptop too hot solution

It works for all Sandybridge systems and up. At least on Core i, pentium and Celeron, might not apply to Atoms.

Offline

#5 2012-12-05 01:44:59

Super-Nathan
#! CrunchBanger
From: South Korea
Registered: 2009-12-18
Posts: 158
Website

Re: Intel laptop too hot solution

The best solution would just be a newer kernel. There are known problems with the <=3.2 kernels and newer (ivybridge) Intel chips


#echo "Something useful" > /dev/null

PiBang Linux

Offline

#6 2013-02-01 03:35:04

typewriterjason
#! Junkie
Registered: 2011-08-28
Posts: 250

Re: Intel laptop too hot solution

My EEEpc is running an Intel Atom; would there be any risk to me adding this to my grub menu?


How hot is hot, anyway? When it's charging my laptop gets between 68 and 75 degrees, but not much more than that.


Fortune favors the bold.
#! WALDORF
Asus EEEPC 1001PXD | Lenovo ThinkPad t410

Offline

#7 2013-02-01 11:16:40

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Intel laptop too hot solution

i have the same question as above.
I have #! on exactly the same model of EeePc smile


Crunchy feeling #!

Offline

#8 2013-02-01 11:20:27

M.I.H.H
#! CrunchBanger
From: /etc/init.d/
Registered: 2012-11-01
Posts: 112
Website

Re: Intel laptop too hot solution

Super-Nathan wrote:

The best solution would just be a newer kernel. There are known problems with the <=3.2 kernels and newer (ivybridge) Intel chips

i agree with you.


Sorry for my bad english smile
i will continue to seek knowledge.
WiFi Ralink RT3290 | Intel IPS | Samba on Thunar
I blog at: billnode

Offline

#9 2013-02-01 11:26:54

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Intel laptop too hot solution

Run lspci -knn on Atoms, if the driver is i915, you can go ahead and do this trick. However, the rc6 solution seems to be integrated into the newer kernel in Wheezy, so a simple dist-upgrade might suffice (I'm on 3.7 from experimental so I don't know precisely). If the Atoms are on GMA500 (the infamous Pulsobo), I can't help.

Offline

#10 2013-02-02 08:45:59

TeoBigusGeekus
#! Die Hard
From: /Greece/Kastoria
Registered: 2012-04-28
Posts: 957

Re: Intel laptop too hot solution


Please make Autocad Civil 3D and Archicad work on Linux!
Please make Autocad Civil 3D and Archicad work on Linux!
Please make Autocad Civil 3D and Archicad work on Linux!
Please make Autocad Civil 3D and Archicad work on Linux!

Offline

#11 2013-02-02 15:10:35

morlog
Member
From: austin
Registered: 2012-06-12
Posts: 38

Re: Intel laptop too hot solution

typewriterjason wrote:

My EEEpc is running an Intel Atom; would there be any risk to me adding this to my grub menu?


How hot is hot, anyway? When it's charging my laptop gets between 68 and 75 degrees, but not much more than that.



I hava an acer d257 with an atom n570 in it.  The i915 kernell drivers are present and working on my netbook. No problems have come up so far and I added these options to grub a while ago.  I did notice that after I added the options that the graphics on my computer seemed to stand out a lot better, became a bit more vivid you could say.


I have a signature

Offline

#12 2013-02-19 06:29:38

seasonz
New Member
Registered: 2013-02-19
Posts: 2

Re: Intel laptop too hot solution

t also works with the Ultrastudio USB 3.0.

In fact, I also connected a USB 3.0 external hard drive at the same time, and captured HD (MJPEG) to it. Wasn't sure if there was going to be enough bandwidth to pull that off, but it did.

EDIT:

For the record, the laptop came with Windows 8, but I reformatted it and put Win 7 Ultimate on it. The USB 3.0 driver I got from the Intel site, not Asus'.

Offline

#13 2013-02-28 11:57:08

maodogo
Member
From: COLOMBIA
Registered: 2013-02-21
Posts: 23
Website

Re: Intel laptop too hot solution

Also you can unload modules you dont use.
For example I get connected by wifi to the net, then I disable ethernet module.

$sudo -i
#lsmod:
bluetooht
lp
parport
ppdev
joydev
r8169
ipv6

if i try to do "modprobe -r r8169" it don't work cause this modules is need it by an other.
so I blacklisted it like this:

#nano /etc/modprobe.d/custom.com
install r8169 /bin/false
install mii /bin/false

and I do the same with blueetooth, lp and parport (parallel port), joydev, ipv6 and ppdev:

install bluetooth /bin/false
install lp        /bin/false
install parport   /bin/false
install ppdev     /bin/false
install joydev    /bin/false
install r8169     /bin/false
install ipv6      /bin/false

You can disable modules in grub too, just add to the "GRUB_CMDLINE_LINUX_DEFAULT"  this  "r8169.disable=1 mii.disable=1"

#nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT= "r8169.disable=1 mii.disable=1"

Finally use "modinfo" to know the information and funtion of a module:

root@crunchbang:~# modinfo lp
filename:       /lib/modules/3.4.0-23.dmz.1-liquorix-amd64/kernel/drivers/char/lp.ko
license:        GPL
alias:          char-major-6-*
depends:        parport
intree:         Y
vermagic:       3.4.0-23.dmz.1-liquorix-amd64 SMP preempt mod_unload modversions
parm:           parport:array of charp
parm:           reset:bool

Last edited by maodogo (2013-02-28 12:00:15)


"In this world, things are complicated and are decided by many factors. We should look at problems from different aspects, not from just one." MZ

Offline

#14 2013-03-20 12:29:52

aleza66
Member
Registered: 2012-08-26
Posts: 10

Re: Intel laptop too hot solution

My hot intel was resolver, by:

Opening the cover, until I reached the CPU heat sink. It had literally a half inch thick barrier of dust all over the heat dissipator from the inside.

problem solved for me.

Offline

#15 2013-03-26 19:08:04

catman
New Member
Registered: 2013-03-25
Posts: 3

Re: Intel laptop too hot solution

thanks ed for the useful info.. i just tweaked it a little more with:

GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1"

Offline

#16 2013-03-26 22:24:30

dura
Bloated Gimp
From: interzone
Registered: 2012-09-15
Posts: 2,108

Re: Intel laptop too hot solution

I am using rc6=7 and it tastes great.

Offline

#17 2013-03-26 22:56:42

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Intel laptop too hot solution

I move to have this unstickied. AFAIK, all the changes have been merged into the default Wheezy kernel, so said advice could even prove harmful. Plus, with me no longer using Debian, I have no way to test anything really.

Offline

#18 2013-03-27 20:44:34

catman
New Member
Registered: 2013-03-25
Posts: 3

Re: Intel laptop too hot solution

using the 3.8-4.dmz.2-liquorix-amd64 kernel now with no options.. :-)

Offline

#19 2013-04-20 06:48:46

ginkocosplayer
New Member
Registered: 2012-08-22
Posts: 9

Re: Intel laptop too hot solution

Would a Dell Inpsiron Mini 1010 fall into this category? It does get somewhat hot and the battery life is not great but I always thought this was normal.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo