SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-12-18 15:24:09

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

SOLVED: waldorf freezing completely on toshiba z930

Waldorf is freezing completely on toshiba z930 on an intermittent basis.  Passage of time will not resolve the issue, I have to use the power off button. The specifications for the laptop are presented in this link:
http://www.toshiba.ca/web/product.grp?s ... part=13950

bash-4.2# lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
01:00.0 System peripheral: Ricoh Co Ltd Device e823 (rev 07)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
bash-4.2# 

I have installed waldorf on another laptop, a MSI 340 X and there is no such problem.

What is there to do?

Last edited by francois.e (2013-03-29 21:03:16)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-12-18 20:21:30

fatmac
#! Die Hard
Registered: 2012-11-14
Posts: 1,948

Re: SOLVED: waldorf freezing completely on toshiba z930

Not really an answer, but I have a laptop that doesn't behave & I think it is my touchpad that is the problem; try booting with an external mouse attached & see if it remains stable.


Linux since 1999
Currently:  AntiX, & Crunchbang.
A good general beginners book for Linux :- http://rute.2038bug.com/index.html.gz
A good Debian read :- http://debian-handbook.info/get/now/

Offline

#3 2012-12-19 18:05:34

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

I work all the time with an external mouse attached. Did you disabled the touchpad?

Offline

#4 2012-12-20 08:12:40

Super-Nathan
#! CrunchBanger
From: South Korea
Registered: 2009-12-18
Posts: 158
Website

Re: SOLVED: waldorf freezing completely on toshiba z930

I have a Toshiba Z30 also (twinzies)

The problem has to do with the fact that our computers are just too damn new for the 3.2 kernel that Debian is shipping in both Sid and Testing. The only option to have your computer not freeze inter. is to install a newer kernel. Don't panic! the fix is pretty easy.

There are a great group of guys that have a distro based off of Debian Sid, called Siduction since they want not only sid packages in their distro, but also the newest kernel, they have a repo, that is compatible with #!, that you can install the kernel from.


To get a Siduction Kernel

1) Edit your /etc/apt/sources.list Add the following:

## Siduction (Base is where the Kernel is)
deb [url]ftp://ftp.spline.de/pub/siduction/base[/url] unstable main contrib non-free
deb-src [url]ftp://ftp.spline.de/pub/siduction/base[/url] unstable main contrib non-free

After you edit your sources.list you need to add the keyring so that it will authenticate the kernel.

sudo apt-get install --allow-unauthenticated siduction-archive-keyring

Now you must update to make it take effect:

sudo aptitude update

Now you can install the kernel with ONE of the following commands:

sudo aptitude install linux-image-siduction-686

sudo aptitude install  linux-image-siduction-amd64   


Backlight considerations:

In order to make your backlight work better you will also need to edit your /etc/default/grub  and add a simple script to another folder. these all come from Here

in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux elevator=noop acpi_backlight=vendor"

The "elevator=noop" is for my SSD .  (dont forget to "update-grub" )



In order to make the backlight work after resume I need to make an executable script called  /etc/pm/sleep.d/restore_brightness

#!/bin/bash
case "$1" in
   suspend|hibernate)
      #do nothing
   ;;
   resume|thaw)
      echo 7 > /sys/class/backlight/toshiba/brightness
   ;;
   *)
      exit 1
   ;;
esac
exit 0

SSD Considerations:

Since we both have an SSD I edited my /etc/fstab  First I added the following to the bottom:

tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
tmpfs	/home/super/.cache	tmpfs	noatime,nodev,nosuid,size=400M00

This mounts my /tmp folder and my Chromium browser cache in the ram, for less SSD writes and faster browsing.  You will need to change /home/super/.cache to /home/YOUR_USERNAME/.cache

Then I changed my two partitons ( / and /home) from :

# / was on /dev/sda1 during installation
UUID=a8c3b7b8-5511-452b-aaf8-f679f7ac669a /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda3 during installation
UUID=f42559cc-30e0-45f8-a743-c8296066d2c9 /home           ext4    defaults        0       2

TO:

# / was on /dev/sda1 during installation
UUID=a8c3b7b8-5511-452b-aaf8-f679f7ac669a /               ext4    defaults,noatime,discard 0       1
# /home was on /dev/sda3 during installation
UUID=f42559cc-30e0-45f8-a743-c8296066d2c9 /home           ext4    defaults,noatime,discard        0       2

Last edited by Super-Nathan (2012-12-20 08:17:58)


#echo "Something useful" > /dev/null

PiBang Linux

Offline

#5 2012-12-23 03:14:01

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

I am really interested in your proposition. The only problem is that I work with grub legacy, I find it more easy to manage and more accessible.  I think that I could work it out adding the information you proposed for your /etc/default/grub.

Here is my menu.lst:

title CrunchBang Linux sda6 with Linux 3.2.0-3-amd64
root (hd0,5)
kernel	/boot/vmlinuz-3.2.0-3-amd64 root=/dev/sda6 ro noacpi quiet splash
initrd	/boot/initrd.img-3.2.0-3-amd64

Here is what it could be:

title CrunchBang Linux sda6 with Linux 3.2.0-3-amd64
root (hd0,5)
kernel	/boot/vmlinuz-3.2.0-3-amd64 root=/dev/sda6 ro noacpi quiet splash acpi_osi=Linux elevator=noop acpi_backlight=vendor
initrd	/boot/initrd.img-3.2.0-3-amd64

I will try it.

Last edited by francois.e (2012-12-23 03:19:27)

Offline

#6 2012-12-23 05:35:22

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

I get blocked here:

crocro@crunchbang-64:~$ sudo apt-get install --allow-unauthenticated siduction-archive-keyring
[sudo] password for crocro: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package siduction-archive-keyring
crocro@crunchbang-64:~

Any suggestion?

Last edited by francois.e (2012-12-23 05:38:15)

Offline

#7 2012-12-23 05:53:12

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

Ok. I got it sorted out.
1) A modification to your procedure. There is a keyring problem if you don't update the packages with sources. So, before:

sudo apt-get install --allow-unauthenticated siduction-archive-keyring

There had to be a:

sudo apt-get update

2) My home directory is in the same partition as root. What should I do for the home directory when you propose:

# /home was on /dev/sda3 during installation
UUID=f42559cc-30e0-45f8-a743-c8296066d2c9 /home           ext4    defaults,noatime,discard        0       2

3) I am used to script ending in .sh. It seems that /etc/pm/sleep.d/restore_brightness has no .sh at the end of the file. I imagine that this a more recent way of working. Is that the case?

4) After all is done. All I do is reboot?

The fix you provided is really appreciated. wink

Last edited by francois.e (2012-12-23 12:45:57)

Offline

#8 2012-12-23 13:28:22

Super-Nathan
#! CrunchBanger
From: South Korea
Registered: 2009-12-18
Posts: 158
Website

Re: SOLVED: waldorf freezing completely on toshiba z930

Yup, just reboot!


#echo "Something useful" > /dev/null

PiBang Linux

Offline

#9 2012-12-23 13:31:14

Super-Nathan
#! CrunchBanger
From: South Korea
Registered: 2009-12-18
Posts: 158
Website

Re: SOLVED: waldorf freezing completely on toshiba z930

scripts only end with .sh as a usefull way of telling people that a fle in develpment is a script. Jsut like pythons get .py and C code gets a .c
To make a script work all it NEEDs is

#!/bin/bash                           # for a bash script

#!/usr/bin/python                 # for a python script

Once a script is in regular use, and especially for things used by the system or as a standalone program it is common to omit the .sh


#echo "Something useful" > /dev/null

PiBang Linux

Offline

#10 2012-12-23 16:17:04

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,956

Re: SOLVED: waldorf freezing completely on toshiba z930

^ It also needs to have the executable flag set. wink

Offline

#11 2012-12-23 17:29:22

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

Thanks. I will come back to report on the absence of freezing.  lol

Offline

#12 2012-12-27 05:40:45

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

I have had some total additional freeze.

Any other suggestions?

Offline

#13 2013-01-23 10:08:40

lennert_h
New Member
From: Belgium
Registered: 2013-01-23
Posts: 1
Website

Re: SOLVED: waldorf freezing completely on toshiba z930

I'm having the same problem.
I will try to update the kernel with Siduction and post here if it worked for me.
I believe it will since I read this:

"What chipset/video card do you have?  The intel HD 4000/ Ivy bridge stuff freezes like this on the 3.2 - 3.4 kernels for me.  The only solution, I've found is to install the towo kernels from siduction which get rid of this.  Hope this helps.  I thoroghly triaged this on Linux Mint as well which uses the 3.2 kernel."


Samsung Series 5 ULTRA {Windows 8 Pro}{Crunchbang Waldorf}

Offline

#14 2013-03-29 02:04:03

francois.e
#! Member
From: Montréal, Québec
Registered: 2012-03-03
Posts: 85

Re: SOLVED: waldorf freezing completely on toshiba z930

Got it! See:
http://crunchbang.org/forums/viewtopic.php?id=25567

With:

# waldorf settings
deb http://packages.crunchbang.org/waldorf waldorf main
deb-src http://packages.crunchbang.org/waldorf waldorf main

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

And:

fl@crunchbang-64:~$ sudo dpkg --configure -a'sudo dpkg --configure -asudo dpkg --configure -asudo dpkg --configure -a

I finally get:

fl@crunchbang-64:~$ uname -r
3.7-1.towo-siduction-amd64
fl@crunchbang-64:~$ 

And all my freezing with the toshiba z930 went away. At least, for now.

Which is great!

Thanks a lot all.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo