SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-07-14 06:00:57

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Upgrading Shotwell To 18.1.1 [SOLVED]

Posting this here to save someone else the headache I had, because I really like this program.

I like Shotwell to organize my photos.  It does enough for me automatically to make it easy to manage files, and the built-in "publish" button makes it pretty easy to quickly post images to Facebook and Flickr for friends and family.   I like the tagging function and the automatic event creation from EXIF date data.  Even if it's GTK3 now.  sad

Shotwell recently updated to 18.1.1 in order to comply with Flickr's HTTPS-only (yay) requirement.   Prior versions just fail.  But just snagging the deb package doesn't work, so I had to build from the tarball.

This was less easy than expected.  First, the dependency list is pretty damn large to build the thing.

Secondly, the webpage fails to mention a dependency package or three.

Third, it doesn't install the same way as it does from Debian's sources (of course), so removing the prebuilt package first was necessary.

And finally (though not Shotwell's fault) checkinstall decided to be a pain in the posterior (if you have problems with it making subdirectories, check out this solution.)  If you don't know what checkinstall is and you use synaptic or apt-get, check it out.

Anyway, best as I can reconstruct from my package history and the websites, here's the dependency list:

libgee-0.8-dev
libgexiv2-dev
libglib2.0-dev
libglib2-dev
girl1.2-glib-2.0
libgstreamer1.0-dev
libgstreamer-plugins-base1.0-dev
libgtk-3-dev
libwebkitgtk-3.0-dev
libwebkit2gtk-3.0-dev
libwebkitgtk-common-dev
libunique-3.0-dev
libgudev-1.0-dev
libexif-dev
libgphoto2-dev
libgphoto2-2-dev
libraw-dev
librest-dev
libsoup2.4-dev:amd64
libxml++2.6-dev
m4
sqlite3
libvala-0.24-0
valac-0.24
valac-0.24-vapi
desktop-file-utils
gnome-doc-utils

So to recap

sudo apt-get remove shotwell

Install and/or upgrade your dependencies:

sudo apt-get install libgee-0.8-dev libgexiv2-dev libglib2.0-dev libglib2-dev girl1.2-glib-2.0 libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgtk-3-dev libwebkitgtk-3.0-dev libwebkit2gtk-3.0-dev libwebkitgtk-common-dev libunique-3.0-dev libgudev-1.0-dev libexif-dev libgphoto2-dev libgphoto2-2-dev libraw-dev librest-dev libsoup2.4-dev:amd64 libxml++2.6-dev m4 sqlite3 libvala-0.24-0 valac-0.24 valac-0.24-vapi desktop-file-utils gnome-doc-utils

Then change to the directory you want to build in, and...

wget https://download.gnome.org/sources/shotwell/0.18/shotwell-0.18.1.tar.xz
tar xvfJ shotwell-0.18.1.tar.xz
cd shotwell-0.18.1

Then you can do the standard dance:

./configure
make

and then use make install or checkinstall to get up and running.

Offline

Be excellent to each other!

#2 2014-07-14 12:52:50

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 1,010
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

Thanks a lot uriel1998. I was just thinking of upgrading ShotWell to newer version ...


Postpone all your duties; if you die, you won't have to do them ..

Offline

#3 2014-07-14 13:45:52

Sector11
Leonardo da Conci
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,227
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

Run: apt-cache depends shotwell to get the exact dependencies:

    $ apt-cache depends shotwell
shotwell
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo-gobject2
  Depends: libcairo2
  Depends: libexif12
  Depends: libexiv2-12
  Depends: libgdk-pixbuf2.0-0
  Depends: libgee2
  Depends: libgexiv2-1
  Depends: libglib2.0-0
  Depends: libgomp1
  Depends: libgphoto2-2
  Depends: libgphoto2-port0
  Depends: libgstreamer-plugins-base0.10-0
  Depends: libgstreamer0.10-0
  Depends: libgtk-3-0
  Depends: libgudev-1.0-0
  Depends: libjavascriptcoregtk-3.0-0
  Depends: liblcms2-2
  Depends: libpango1.0-0
  Depends: libraw5
  Depends: librest-0.7-0
  Depends: libsoup2.4-1
  Depends: libsqlite3-0
  Depends: libstdc++6
  Depends: libunique-3.0-0
  Depends: libwebkitgtk-3.0-0
  Depends: libx11-6
  Depends: libxml2
  Depends: shotwell-common
  Depends: librsvg2-common
  Depends: dbus-x11
 
 14 Jul 14 | 10:41:26 ~
    $ 

Q&As for Conky v1.9 & v1.10 | Conky Archives | All Conky Threads
.deb file editor | Debian Jessie: BunsenLabs subAlpha & Wally-jr
BL Forum Moderator | LinuxBBQ

Online

#4 2014-07-14 14:04:47

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 1,010
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

Sector11: is this dependecies list for wheezy version (shotwell version 0.12.3) or for the newest version 0.18?

Those two might be different ...


Postpone all your duties; if you die, you won't have to do them ..

Offline

#5 2014-07-14 14:30:18

Sector11
Leonardo da Conci
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,227
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

iMBeCil wrote:

Sector11: is this dependecies list for wheezy version (shotwell version 0.12.3) or for the newest version 0.18?

Those two might be different ...

I apologize --- you are right.  It's the Wheezy/Waldorf version: 0.12.3-2+deb7u1

For Jessie: Package: shotwell (0.18.0-1)

a hiccup:

dep: libc6 (>= 2.14) [amd64]
    GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb 

dep: libc6 (>= 2.7) [not amd64]

For SID: Package: shotwell (0.18.0-1 and others)
an even bigger huccup

dep: libc6 (>= 2.11) [hppa]
    GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb 

dep: libc6 (>= 2.13) [sh4]

dep: libc6 (>= 2.14) [amd64]

dep: libc6 (>= 2.16) [x32]

dep: libc6 (>= 2.17) [arm64]

dep: libc6 (>= 2.7) [not alpha, amd64, arm64, hppa, sh4, x32]

dep: libc6.1 (>= 2.7) [alpha]
    GNU C Library: Shared libraries
    also a virtual package provided by libc6.1-udeb 

I see uriel1998's list doesn't include libc6 so that might be the way to go.   cool

@ uriel1998 - if you run "apt-cache depends shotwell" with your new version does it show your list or the repo list?


Q&As for Conky v1.9 & v1.10 | Conky Archives | All Conky Threads
.deb file editor | Debian Jessie: BunsenLabs subAlpha & Wally-jr
BL Forum Moderator | LinuxBBQ

Online

#6 2014-07-14 17:38:10

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

Sector11 wrote:
iMBeCil wrote:

Sector11: is this dependecies list for wheezy version (shotwell version 0.12.3) or for the newest version 0.18?

Those two might be different ...

I apologize --- you are right.  It's the Wheezy/Waldorf version: 0.12.3-2+deb7u1

I see uriel1998's list doesn't include libc6 so that might be the way to go.   cool

@ uriel1998 - if you run "apt-cache depends shotwell" with your new version does it show your list or the repo list?

No such luck - I already had libc6-dev 2.19-1 onboard (probably from building audacious) so I wouldn't have had to install it new.   ops

And I'm on Jessie, not Sid.  Which I realize now means that I may have mis-posted, but also explains why I didn't have the HUGE list of unmet dependencies you found.  And since I used checkinstall, I get this now:

steven@koala:/home/steven$ apt-cache depends shotwell
shotwell
  Conflicts: shotwell:i386

13:29:52 -------------
steven@koala:/home/steven$ apt-cache depends shotwell:i386
shotwell:i386
  Depends: libatk1.0-0:i386
  Depends: libc6:i386
  Depends: libcairo-gobject2:i386
  Depends: libcairo2:i386
  Depends: libexif12:i386
  Depends: libexiv2-12:i386
  Depends: libgdk-pixbuf2.0-0:i386
  Depends: libgee-0.8-2:i386
  Depends: libgexiv2-2:i386
  Depends: libglib2.0-0:i386
  Depends: libgomp1:i386
  Depends: libgphoto2-6:i386
  Depends: libgphoto2-port10:i386
  Depends: libgstreamer-plugins-base1.0-0:i386
  Depends: libgstreamer1.0-0:i386
  Depends: libgtk-3-0:i386
  Depends: libgudev-1.0-0:i386
  Depends: libjavascriptcoregtk-3.0-0:i386
  Depends: libjson-glib-1.0-0:i386
  Depends: liblcms2-2:i386
  Depends: libpango-1.0-0:i386
  Depends: libpangocairo-1.0-0:i386
  Depends: libraw10:i386
  Depends: librest-0.7-0:i386
  Depends: libsoup2.4-1:i386
  Depends: libsqlite3-0:i386
  Depends: libstdc++6:i386
  Depends: libwebkitgtk-3.0-0:i386
  Depends: libx11-6:i386
  Depends: libxml2:i386
  Depends: <shotwell-common:i386>
  Depends: librsvg2-common:i386
  Depends: dbus-x11:i386
    dbus-x11
  Conflicts: shotwell

Which puzzles me to no end, since the checkinstall package clearly says that it's amd64...   yikes

Offline

#7 2014-07-14 18:33:00

Sector11
Leonardo da Conci
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,227
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

uriel1998 wrote:

And I'm on Jessie*, not Sid.  Which I realize now means that I may have mis-posted, but also explains why I didn't have the HUGE list of unmet dependencies you found.  And since I used checkinstall, I get this now:

Which puzzles me to no end, since the checkinstall package clearly says that it's amd64...   yikes

* Bold - italics mine

- I must have been asleep at the wheel .. it "Clearly" says (Testing/Unstable) up there ie: Jessie  DUH!
- Therefore libc6 is fine for you.

But that i386 stuff is a bummer and puzzling!


Q&As for Conky v1.9 & v1.10 | Conky Archives | All Conky Threads
.deb file editor | Debian Jessie: BunsenLabs subAlpha & Wally-jr
BL Forum Moderator | LinuxBBQ

Online

#8 2014-07-14 23:19:58

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Re: Upgrading Shotwell To 18.1.1 [SOLVED]

Sector11 wrote:
uriel1998 wrote:

And I'm on Jessie*, not Sid.  Which I realize now means that I may have mis-posted, but also explains why I didn't have the HUGE list of unmet dependencies you found.  And since I used checkinstall, I get this now:

Which puzzles me to no end, since the checkinstall package clearly says that it's amd64...   yikes

* Bold - italics mine

- I must have been asleep at the wheel .. it "Clearly" says (Testing/Unstable) up there ie: Jessie  DUH!
- Therefore libc6 is fine for you.

But that i386 stuff is a bummer and puzzling!

I'm glad to know I posted in the right place!  smile

If anyone has a clue why the i386 is getting pulled in, I'd be grateful.  We're in an area where I'm mostly reporting "this didn't break it and seems to work" as opposed to "best practices".

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo