Note: this wiki is no longer maintained. If you have any questions related to this wiki, please post them on the CrunchBang forums.

Translations of this page?:

Z-Obsolete VARIOUS Gedit [OBSOLETE/NEEDS EDITING?]

Gedit is the default text editor for CrunchBang Full, it is accessible from the menu under 'Text Editor', it also has a keybinding W-t (windows/Superkey-t) assigned to it. Gedit is a full featured text editor, including search and replace, syntax highlighting, spell checking, tabs and is extensible through plugins.

Features

  • Syntax Highlighting - Syntax highlighting can be manually selected under View → Highlight mode. Different colour palettes can be selected under Edit → Preferences → Font and colour scheme (tab).
  • Search and Replace - is available on the toolbar, or under 'Search' on the top level menu
  • Spell checking - Documents can be spell checked through Tools → Spell checking … on the top level menu, you can also set spell checking to automatic

Preferences

Preferences can be set under Edit → preferences on the top level menu. It covers things such as syntax highlighting colours, tab width and manages plugins. Further options for the look of Gedit can be set under 'View' on the top level menu, the tick boxes can configure whether things like the side bar or tool bar are shown.

Plugins

Gedit is extensible through plugins, installed plugins can be seen under Edit → Preferences → Plugins (tab) on the top level menu.

Installing Plugins

Plugins need to be downloaded and saved to ~/.gnome2/gedit/plugins, they may come with their own specific installation instructions which should be preferred over this walkthrough.

  • First step is to make the plugins directory, as it doesn't exist by default, either make the directory using your preferred file manager, or in a terminal type:
mkdir ~/.gnome2/gedit/plugins
  • Then download the plugin, by default it will be saved in ~/downloads.
  • The file will probably be compressed, if using a file manager you should be able to extract it through the right click menu, if using a terminal, (for more details on using the terminal see here):
tar xvzf ~/downloads/downloaded_file.tar.gz

Note: this assumes the file is a tar.gz archive, see the man page for other options

man tar
  • Then put all files and subfolders from the decompressed file in the plugins directory, either using your preferred file manager or in a terminal type:
cp -r ~/downloads/downloaded_file/* ~/.gnome2/gedit/plugins
  • Then start Gedit, your plugin should appear under Edit → Preferences → Plugins (tab), tick the box to enable it.

Links

(machinebacon) It's not a default anymore. Unsure if it deserves an own wiki page here.

 
gedit.txt · Last modified: 2012/05/24 08:35 by machinebacon
Except where otherwise noted, content on this wiki is licensed under the following license:CC Attribution-Share Alike 3.0 Unported

Powered by DokuWiki. Hosted by Linode.
Copyright © 2010 CrunchBang Linux.
Proudly powered by Debian GNU/Linux.
Debian is a registered trademark of Software in the Public Interest, Inc.